Best of r/RemarkableTablet

Connecting to Eudroam with a certificate using wpa_supplicant - by anlucia with 0 comments

Hi,

my new university has Eduroam setup in such a way that you need to use a certificate to connect (I tried without and it didn’t work). I have followed (with some modifications I will describe later) the instructions given in the wiki, and they “kind” of work, but in a weird and not really convenient way. I am trying to figure out what the issue is, maybe somebody can help me out.

My setup

I’ve created /etc/wpa_supplicant/wpa_supplicant-wlan0.conf, containing the following:

ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=0

network={
        ssid="eduroam"
        id_str="eduroam"
        key_mgmt=WPA-EAP
        pairwise=CCMP
        group=CCMP TKIP
        eap=TTLS
        ca_cert="/etc/wpa_supplicant/ca-eduroam.crt"
        phase2="auth=PAP"
        identity=[USERNAME]
        anonymous_identity="[email protected][UNIVERSITYDOMAIN]"
        password=[PASSWORD]
}

where [USERNAME]/[UNIVERSITYDOMAIN/[PASSOWORD] are the ones I use to connect at my university, and the certificate is the one they provided.

Then if I run systemctl enable [email protected] and systemctl start [email protected], it won’t connect. This is the output of journalctl -u [email protected]:

reMarkable wpa_supplicant[1154]: wlan0: Associated with xx:xx:xx:xx:xx:xx
reMarkable wpa_supplicant[1154]: wlan0: CTRL-EVENT-SUBNET-STATUS-UPDATE status=0
reMarkable wpa_supplicant[1154]: wlan0: CTRL-EVENT-REGDOM-CHANGE init=COUNTRY_IE type=COUNTRY alpha2=ES
reMarkable wpa_supplicant[1154]: wlan0: CTRL-EVENT-DISCONNECTED bssid=xx:xx:xx:xx:xx:xx reason=0 locally_generated=1
reMarkable wpa_supplicant[1154]: wlan0: CTRL-EVENT-SSID-TEMP-DISABLED id=0 ssid="eduroam" auth_failures=4 duration=77 reason=CONN_FAILED
reMarkable wpa_supplicant[1154]: wlan0: CTRL-EVENT-REGDOM-CHANGE init=CORE type=WORLD
reMarkable wpa_supplicant[1154]: wlan0: CTRL-EVENT-REGDOM-CHANGE init=USER type=COUNTRY alpha2=ES
reMarkable wpa_supplicant[1154]: wlan0: CTRL-EVENT-SCAN-FAILED ret=-16 retry=1
reMarkable wpa_supplicant[1154]: wlan0: CTRL-EVENT-SSID-REENABLED id=0 ssid="eduroam"
reMarkable wpa_supplicant[1154]: wlan0: Trying to associate with SSID 'eduroam'

and so on. In dmesg there is this:

brcmfmac: brcmf_cfg80211_escan: Connecting: status (3)
brcmfmac: brcmf_cfg80211_scan: scan error (-11)

How I made it work:

Now, if I do the following:

  1. disable the wifi via the GUI interface
  2. run systemctl restart [email protected]

Then it will connect:

reMarkable wpa_supplicant[1433]: wlan0: Associated with xx:xx:xx:xx:xx:xx
 reMarkable wpa_supplicant[1433]: wlan0: CTRL-EVENT-EAP-STARTED EAP authentication started
reMarkable wpa_supplicant[1433]: wlan0: CTRL-EVENT-SUBNET-STATUS-UPDATE status=0
reMarkable wpa_supplicant[1433]: wlan0: CTRL-EVENT-REGDOM-CHANGE init=COUNTRY_IE type=COUNTRY alpha2=ES
reMarkable wpa_supplicant[1433]: wlan0: CTRL-EVENT-EAP-PROPOSED-METHOD vendor=0 method=21
reMarkable wpa_supplicant[1433]: wlan0: CTRL-EVENT-EAP-METHOD EAP vendor 0 method 21 (TTLS) selected
reMarkable wpa_supplicant[1433]: wlan0: CTRL-EVENT-EAP-PEER-CERT depth=1 subject='[...]' hash=[...]
reMarkable wpa_supplicant[1433]: wlan0: CTRL-EVENT-EAP-PEER-CERT depth=0 subject='[...]' hash=[...]
reMarkable wpa_supplicant[1433]: wlan0: CTRL-EVENT-EAP-SUCCESS EAP authentication completed successfully
reMarkable wpa_supplicant[1433]: wlan0: CTRL-EVENT-CONNECTED - Connection to xx:xx:xx:xx:xx:xx completed [id=0 id_str=eduroam]

It won’t try to connect to the cloud yet (I guess it believes that it is not connected to anything), but if I enable the wifi again from the GUI it will stay connected to eduroam and it will sync with the cloud. Horray!

​

But this is really inconvenient: every time I need to switch wifi, or suspend the remarkable, I need to ssh in and do this dance of disable-restart-enable. What is going on here? Any thoughts?

Remarkable2 never fully charges - by IonizedRay with 1 comments

I have a 2A 5V charger that i use together with the stock cable and it goes quite rapidly from 0% to 70%. However at some point the battery “freezes” at 75% or 85% or even 97% sometimes.

After that, it sits on that percentage for more than 20 hours. Usually i unplug it after 5 hours that it’s stuck.

What could it be? Someone is experiencing the same problem?

Remarkable 2 Crashing Frequently - by Zementid with 0 comments

When the remarkable tablet was unused for a few hours it crashes (Black/white display, Boot screen and back to main menue).

Anyone else with this behavior?

How to highlight text with KOReader ? - by Think-Ad6669 with 0 comments

I don’t understand how to highlight text in KOReader, is it even possible ?
It must be very obvious, but I’m stupid enough to not being able to see it…

Created this flowchart in my remarkable. What do you all think? - by Objective_Employ4295 with 0 comments

ISO used book folio (RM2) - by amiocamp with 0 comments

Anyone have an official book folio for the RM2 that you’re interested in selling?

I tried one option from Amazon and absolutely hated the way the fabric lining felt and could not stand to use it. I’ve mostly accepted that the official book folio is my best option for the time being but would prefer to buy a gently used one rather than order brand-new.

Shoot me a DM if you are not loving your book folio and want to recoup some of the cost!

Oh, I also picked up one of these plastic cases from Etsy. Inexpensive and quite good for at-home use (not wild about the pen holder though, it’s a bit too tight), but I need screen protection for traveling.

Thanks!

2.8 Update - by Alariii with 0 comments

Apparently rolling out: https://support.remarkable.com/hc/en-us/articles/4402369246865

I have no idea what they’re doing or why… A while back they confirmed to me, that layer persistence is a thing they are aware of, that people want and would be worked on.

Now they finally get to touching layers stuff, and instead of doing something that’s actually useful (that when you tweak layer visibility or, it and the active layer would be the same when you reopen the notebook the next time, really really easy to establish, since they already store plenty of metadata with the files) they add extra complications to which was supposed to be simple paper, and which is used most of the times as an excuse when people ask for features.

AND layer merge existed before already, it could’ve been established by select -> cut/copy -> paste to another layer -> delete or reuse old layer. Don’t even know who’d need it. The layer persistence issue however is something that is a system shortcoming, as most of the times with multilayer documents, you end up writing on the wrong layer, because you forgot to check and can’t easily come back from it when your stuff is already intertwined with the other stuff on that layer.

End of rant

Connection Issues - by GiantBullFrog with 0 comments

Has anyone else experienced issues with connecting to wifi and the cloud and staying connected? If so how did you solve it? I just got the tablet today and don’t know much. Thank you!

How do you make hyperlinks work? I can’t seem to do it. - by sonder-and-hiraeth with 0 comments

I have a PDF with hyperlinks in it and when I import to Remarkable they cease to work.

Is this something you can only do with Remarkable 2? If not, how do I make it work?

Can you choose what folders get synced to remarkable cloud? - by DataAnalyticsIreland with 0 comments

Hi,

Using rm2, liking it. I want to look at Using its cloud services, but don’t want to upload all my files, is that possible?

Thanks,

Joe

RM1/RM2 Dynamic Lock-screens - sorta works still? - by makeavoy with 0 comments

I thought you all may interested in knowing this old trick still works http://abcxyz.de/2017/12/07/turn-rms-suspended-screen-in-something-useful/

The trick is to locate the .thumbnail folder in xochitl and then soft link the .jpg image instead. Yes you can in fact softlink a jpeg to a png apparently and it’ll accept it. Who knew? Just remember to rename or delete the old suspended.png first, of course.

This is what my command looked like:
ln -s /home/root/.local/share/remarkable/xochitl/a8bbbd19-cb6b-423d-8af1-f7497c43c764.thumbnails/3ebc575e-9381-4bec-8ed8-7f376e47dc51.jpg /usr/share/remarkable/suspended.png

There are two draw backs to this.

  1. It is it is using a thumbnail, so it’s a bit pixelly looking. Personally I don’t mind, I have big notes.
  2. And more importantly, it will only update on a restart or power cycle. This stinks but if it doesn’t change too often it’s a lot less extra steps then trying to ssh or sshfs into the device every-time you want to update it. Just make changes to your note and do a quick restart. Maybe the power off screen could be soft linked also, I haven’t tried it?

Looking for a budgeting template… - by gimletrose with 0 comments

Hi all,
I had just bought reMarkable 2 and looking for a template for budgeting my household. I found a website with whole lot of templates but it requires me to download their program to my computer and I am skeptical. Does any of you have a good PDFs you use?
I currently use Clever Fox Budget Planner and I’m looking for something similar.

Remarkable 2 has regions where stylus is inaccurate, up to 1mm off the tip. Is this a defect or to be expected? - by YannZed with 1 comments

What drawing tool works best for you? - by aerique with 0 comments

When I initially started drawing on the Remarkable 1 I picked the pencil but I never really liked it. I’m now using the fineliner on gray because it feels more like a real pencil to me. With the Remarkable pencil tool I feel I have to press too hard to get a similar line to what I would get on paper.

What about you guys?

It looks like the ReMarkable will be great for future chem courses - by GiantBullFrog with 0 comments

Was feeling froggy - by Airlineguy1 with 0 comments

Remarkable 2 for sale In mint condition with a black leather folio, the marker pen, and a lami pen. I paid over $700 and have downloaded the hacks for it which can be reversed. Selling for $400 plus shipping. I don’t have any room for it with my iPad Pro. - by Comfortable-Shower14 with 0 comments

ReMarkable for Maths and Stats - by sarah_hawkes_28 with 0 comments

This is a post for anyone thinking of getting a ReMarkable 2 for university/college.

DO IT. DO IT NOW.

I am a Maths/Stats/Comp Sci major and was looking at upgrading my laptop to a 2-in-1 a few months back because using pen and paper for maths, especially assignments which then had to be scanned and condensed to a PDF for submission, was killing me. I decided to wait until end of financial year to try and get a bargain, but the next day an ad for ReMarkable showed up in my Insta feed. I had never heard of it before but I knew it was perfect for what I needed and it would be a companion to my laptop, rather than a replacement, and at half the cost of what I’d been looking at. I took the plunge and bought it.

It was delivered within a week and I fell in love straight away. I get to organise all my stuff the way I like it, I can copy and paste parts of equations I’ll be reusing a lot (a major time saver in exams), and if I completely mess something up I can just erase all instead of wasting an entire page of paper or six tonne of whiteout. The highlighter function for notes is awesome!! Being able to annotate lecture notes on it is amazing, and really helps me to engage with the work.

Recently I had stay-home exams and they were a breeze with the ReMarkable. If I had waited for sales like I planned, I would have done my exam all on paper and then scanned each page within the exam time for submission. That would have taken so long! Instead, I did it on the ReMarkable and exported and it took about ten seconds flat to get the assignment from my tablet to the submission portal. What I will say is I recommend when using graph paper is starting each question on a new page, then exporting everything as PNGs for submission. Exporting as a PDF makes the lines on the graph paper black and it makes it tricky to read sometimes, but it doesn’t happen with PNGs. Also means you can submit per question if that is what your exam requires.

Being able to write everything but still be digital is great for maths and stats, especially with diagrams and Greek symbols needed. Can’t recommend highly enough!!

In the wild - by fabfianda with 0 comments

Can you add your own template (and if so, how)? - by JamminInCam with 0 comments

My apologies if this question has already been asked but I just recently received a Remarkable as a gift so I haven’t had a lot of time to explore this subreddit (I’m also sorry is this in under the wrong flair; if it is, let me know and I’ll change it). I’m using the tablet mainly to take notes, as I’m a post-graduate student, but I also love drawing and design. I was just thinking today how great it would be if there was a mannequin template so I wouldn’t have to sketch one every time I drew something. There are other template ideas I’d love to see, but that’s just one.